Plugin no work

More
5 years 2 months ago #1 by cataplana
Replied by cataplana on topic Plugin no work
think I´ll deactivate until some solution appeares...

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #2 by cataplana
Replied by cataplana on topic Plugin no work
checked....

changed "Menu associations" from no to yes.


still the same.... :(

Tried cleaning cache... tried several explorers...

still the same: 4 languages work, 3 dont...
Last edit: 5 years 2 months ago by cataplana.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #3 by laurelle
Replied by laurelle on topic Plugin no work

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #4 by cataplana
Replied by cataplana on topic Plugin no work
jepp, that is strange indeed...

first i checked the menus...

to become a client (costumer) the link leads to "index.php?option=com_users&view=registration" in every language.

I do really not know, where elso to look for what could be the reason....

Meanwhile I had to disable your plugin, because 70% of the pages visitors a either portuguese or german...

By the way: what do you mean with "check the languages set up?"
Last edit: 5 years 2 months ago by cataplana.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #5 by laurelle
Replied by laurelle on topic Plugin no work
cataplana wrote:

Hi,

my Shop adress is www.cataplana-shop.com

the redirection works fine with the english, frensh, italian and spanish language, when the option "register" is chosen.

It does not work in german, dutch and portuguese.

Is that, because it is not compatible with the languages?

Could somebody please give my an advice, because it is not realy making sense to me.

Thanks !

Joomla! version: 2.5.16
VirtueMart version: 2.0.24a
KC Extension version: 1.3.1
PHP version: 5.3.27


Hi,

If the plugin works for some languages and not others I think the problem is with the language setup for the ones that aren't working. Is there something different with the language setup for german, dutch and portuguese than for the other languages? The plugin is using standard Joomla language code, so it doesn't care what language is choosen as long as it is setup correctly.

Having said that, I have never used the plugin in a multi-language environment, so I don't know what could be the issue and this is the first time it has been reported.

Please check your setup for the 3 none working languages.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #6 by cataplana
Replied by cataplana on topic Plugin no work
Great for you !

If it works on chinese, it should work on portuguese or german too....

I am looking forward to the solution ;)

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #7 by maniee
Replied by maniee on topic Plugin no work
Hi, I forgot to say thank you to your great plugin that always works very well to redirect the Joomla Login page to the Virtuemart Registration page. Thanks a lot for your great effort put in to make such a great and free plugin for Virtuemart users like me.

Your great plugin works very well in my Chinese Joomla2.5!

Thank you so much for your great and free plugin!

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago - 5 years 2 months ago #8 by cataplana
Replied by cataplana on topic Plugin no work
Hi,

my Shop adress is www.cataplana-shop.com

the redirection works fine with the english, frensh, italian and spanish language, when the option "register" is chosen.

It does not work in german, dutch and portuguese.

Is that, because it is not compatible with the languages?

Could somebody please give my an advice, because it is not realy making sense to me.

Thanks !

Joomla! version: 2.5.16
VirtueMart version: 2.0.24a
KC Extension version: 1.3.1
PHP version: 5.3.27
Last edit: 5 years 2 months ago by cataplana.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #9 by laurelle
Replied by laurelle on topic Plugin no work
Hi,

The only thing that VM Registration Redirect plugin does is change a Joomla User registration link to a VM registration link. It has nothing to do with the actual registration process. Registering and getting the email message is all VM functionality. If the activation link in the email is not working, that is a VM issue and you should report it on the VM forum.

If you try to go to the Joomla registration page and you are instead being taken to the VM registration page, the plugin is working.

The menu item id in the VM Registration redirect plugin should be the menu item id for a VM registration page.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #10 by maniee
Replied by maniee on topic Plugin no work
I'm not sure about this. The new site is currently under making and testing.
As far as I know that Virtuemart doesn't support Joomla login well so I have disabled the user auto registration function from the Joomla backend in user manager. Such doing so, that means whether I have used a redirect plugin or not is not important as a result.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #11 by Virtuemart
Replied by Virtuemart on topic Plugin no work
maniee wrote:

Hi, the link is attached
218.253.172.75:8080/t5/index.php/hong-ko...e/shippable-products/rioja-red-wine/cart

Maybe it's cos your domain address is numeric?

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #12 by maniee
Replied by maniee on topic Plugin no work
I have installed
plugin_system_kc__vm_registration_redirect-1.3.1.zip
in my Joomla2.5.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #13 by maniee
Replied by maniee on topic Plugin no work
I am using Joomla2.5 and Virtuemart2.0.24 and PHP5.4.

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #14 by maniee
Replied by maniee on topic Plugin no work
Hi, the link is attached
218.253.172.75:8080/t5/index.php/hong-ko...e/shippable-products/rioja-red-wine/cart

After registration and receiving an email notification to click on the link to activate my user account, I click on the link and could not be able to redirect to
index.php?option=com_virtuemart&view=user&task=edit that I created it in the new menu and set the menu id in the plugin.

Please help to see how to fix the problem and make your plugin work. Thank you~

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #15 by laurelle
Replied by laurelle on topic Plugin no work
Hi,

What is your problem exactly, what is not working for you?

Can you pass a link to your page that the registration is not working on?

What version of Joomla, Virtuemart, KC VM Registration Redirect & php do you have?

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
5 years 2 months ago #16 by maniee
Replied by maniee on topic Plugin no work
Yes, it doesn't work completely after enabled it and set a correct menu id in the plugin. Why the thing happens like this? Any idea that you can give me to make this plugin work properly?

Look forward to hearing from you~

Please Log in or Create an account to join the conversation.

More
5 years 4 months ago #17 by laurelle
Replied by laurelle on topic Plugin no work
Hi,

When you disabled SEF URLs what was the URL that you got when you clicked the Create Account link?

The plugin will only redirect the registration link, it will not redirect the login link.

Did you try adding a menu item id for your virtuemart registration page in the plugin parameters?

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
5 years 4 months ago #18 by gabriela
Plugin no work was created by gabriela
I can't run the plugin. Is enabled and I have still only joomla login.
I tried in several ways:
1. creating a menu item to a login form (follow the joomla)
2. creating a module with the login form (follow the joomla)
3. I disabled the SEF UR's (I saw it in a post on the forum)
What am I doing wrong?

Joomla! version: 2.5
VirtueMart version: 2.0.20b
KC Extension version: 1.3.1
PHP version: 5.3.27

Please Log in or Create an account to join the conversation.

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Hosts

Managed Web Hosting by Liquid Web

This is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top