Cufon doesn't work on Firefox - OK in IE

More
8 years 2 months ago #1 by laurelle
Hi,

Yes, having a site link and the parameters is very helpful.

You have a JS error somewhere, in Firebug I see:
The expression is not a legal expression." code: "51
line 54 of mootools.js. This could be what is causing the problem.

When I look at the source code the plugin has set everything up as it should. Either the JS error that you have or your template menu code is conflicting with the Cufon JS.

Try fixing the JS error and see if that fixes the problem. If not, I believe that Joomlarts has some method of providing different fonts in their templates already. You could try that avenue. Otherwise this is a Cufon JS problem and you would need to contact the Cufon developers at: github.com/sorccu/cufon/wiki/

Good luck.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by jcbazil
Hello there..

I attached the setting i use. The link is here : jarasite.leokurupong.com/

When i open using Firefox, the font still using the default font. But when using IE the font changed to the font i set on the cufon.

Appreciate your help. Thanks.
Attachments:

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #3 by laurelle
Hello,

You having given any information that would enable me to help you.

What version of the plugin are you using?
What version of Joomla are you using?
What is the link to the page that isn't working?
Did you make sure that the plugin was working after you installed it with the default settings and fonts before making changes, if not go back and do that step?
What parameter settings do you have?
Are you using your own Cufon generated font file?

I need some information in order to suggest possible problems.

Have you read the Usage, Installation & FAQs on this page: http://www.keashly.net/typography/kc-cufon-font-replacement

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago - 8 years 3 months ago #4 by jcbazil
Hi,

I have problem when i configure the cufon on Firefox, it doesn't work. But when i check on IE it work. Appreciate your help. Thanks a lot!
Last edit: 8 years 3 months ago by jcbazil.

Please Log in or Create an account to join the conversation.

Joomla! & WordPress Hosts

Liquid Web is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress. Their technicians go above and beyond what other hosting providers do, in our opinion.

  

Liquid Web Managed Word Press   

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top