doesn't seem to work

More
9 years 3 months ago #1 by laurelle
Replied by laurelle on topic doesn't seem to work
Hello,

You have defined h3 in both font 1 and font 2. Remove it from one of them.

Are you sure the font name is OCR_A_Std? When you are generating the font, fill in the font family name field, just to be sure. Try checking All in the glyphs section. Leave the domains field empty in the Security section. Try that font file and see if that works.

Cheers.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #2 by windburger
Replied by windburger on topic doesn't seem to work
Yes I upload it to the same folder (plugins/system/kc_cufon/fonts)

Yes I use the same name minus the .font.js

I try both way with or without www version

here some pict

Attachment printcscreen2.jpg not found

Attachments:

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #3 by laurelle
Replied by laurelle on topic doesn't seem to work
Hello Martin,

There could be many reasons why it isn't working with the new font.

Did you upload the new .js font file to /plugins/system/kc_cufon/fonts, leaving it named the same as the cufon generator names it?
Did you put that exact name minus the .font.js in the font file parameter. Are you sure that you have the correct name for the font in the parameter file?

When you generated the file, did you specify a domain? If so, did you make sure you used both the www version and the non-www version?

You will have to give more information for me to be able to help you, but I suggest that you read the Usage instructions and FAQs.

Good luck.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #4 by king okkie
Replied by king okkie on topic doesn't seem to work
i think you are in the wrong topic martin?

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #5 by windburger
Replied by windburger on topic doesn't seem to work
I want tu use it whit joomla !

It work 100% with the 3 font that you give when we upoload it.

I when to upload a new font after I past it with the generator and give me a .js file that I upload to the my server.

But still it doesn't work the font don't change why ?

Thank in advance

Martin

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #6 by laurelle
Replied by laurelle on topic doesn't seem to work
Hi,

Great. Glad you got it working.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #7 by king okkie
Replied by king okkie on topic doesn't seem to work
o Yesssss , i got it up and running.
i did it the way you sayed and the font is now showing on my site.
Thanks a lot for the quick support and the great plugin (this is a must have !!)

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #8 by laurelle
Replied by laurelle on topic doesn't seem to work
Hello,

Did you make sure that your site was working with the default fonts before you tried changing the fonts? I suspect that the default fonts weren't working since you aren't calling an AJAX framework in the head of your document. Cufon needs an Ajax framework, which needs to be called before the Cufon Javascript calls. Most Joomla templates automatically import the mootools framework, but I don't see that call in the source you posted below. So, that would be problem 1 to solve.


Secondly, you can't define the same selectors twice. You have h1 to h6 defined for both fonts. You can't have an h1 displayed in 2 different fonts. If you want h1 in Analog and h2 in Concorde, then you only specify them once for the font and not for the font you don't want them displayed in. So you would remove h2 in CSS selectors for Font 1 and remove h1 for CSS Selectors for font 2. (You also need to remove one of the definitions for h3 to h6).

Get the default fonts working on say h1 and h2, then change the CSS selectors to the ones you want for Font 1 and Font 2, get that working. Then change font 1 to the actual font you want, get that working. Then change Font 2 to the new font.

Trying to change everything at once, you don't know where the problem is.

Good luck.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago - 9 years 3 months ago #9 by king okkie
Replied by king okkie on topic doesn't seem to work
screenshot 2
Attachments:
Last edit: 9 years 3 months ago by king okkie.

Please Log in or Create an account to join the conversation.

More
9 years 3 months ago #10 by king okkie
The plugin doesnt see to work for me after 3 day's of trying.
I have very (read: VERY) limited html/css skills so thats part of the problem but i hope anyone can help.
I like to use the concorde font for the titels and the analog font for the content

-the installation of the plugin and generating the fonts went well.
I also think the parameter are ok (screenshot 1)
-then i edited the html code of the (artisteer)themplate (screenshot 2)
not so sure this is ok

i changed nothing to the themplats css (!) but i can see the analog font is there in the code.

what am i doing wrong/forgetting?
Attachments:

Please Log in or Create an account to join the conversation.

Joomla! & WordPress Hosts

Liquid Web is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress. Their technicians go above and beyond what other hosting providers do, in our opinion.

  

Liquid Web Managed Word Press   

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top