SOLVED Problem with one font

  • blog_elimu_pl
  • Topic Author
9 years 2 months ago - 9 years 2 months ago #1 by blog_elimu_pl
Replied by blog_elimu_pl on topic SOLVED Problem with one font
You are right The problem is only with this one font, rest is working , after I changed the Name to name without "_400".

But How to check easy witch name is good, not name of file, but name of font?

I get it... :woohoo: "Neo Sans Pro" name was in font.js - It was example , for testing only when I stuck.
Last edit: 9 years 2 months ago by blog_elimu_pl.

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #2 by laurelle
Hello,

If the font file worked with the example scripts then I suspect that the font name you used was incorrect in the Plugin parameters. Did you set the font to: Neo_Sans_Pro and the font file to: Neo_Sans_Pro_400? Did you make sure that the number of fonts being used was changed to include your new font?

When you created the font file did you specify the name of the font? If so, that is what you need to enter in the plugin parameters font name field. Did you specify the website that the font file can be used on? If so, did you include both the www and non-www version of your domain?

Try including a screencap of the plugin parameters, so I can see how you have things setup. Also a link to your site so I can see the source code to make sure things are being included in the correct order.

Does your template include Mootools or JQuery? One of these libraries need to be included before the cufon JS files.

Hope that helps.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • blog_elimu_pl
  • Topic Author
9 years 2 months ago - 9 years 1 month ago #3 by blog_elimu_pl
SOLVED Problem with one font was created by blog_elimu_pl
I tried Cufon plugin and with default fonts it works okey.
Later I create font using cufon.shoqolate.com/generate
and my fonts doesnt' work. But when I use example scripts from github.com/sorccu/cufon - puting there my font it was okey, even was polish letters.
So I'm stupid what's wrong, I undersand info so...

I forgot, I used NeoSansPro-Regular.otf to create Neo_Sans_Pro_400.font.js

Help :(
Last edit: 9 years 1 month ago by laurelle.

Please Log in or Create an account to join the conversation.

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Hosts

Managed Web Hosting by Liquid Web

This is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top