cufon canvas adds top -1 to element

More
7 years 3 months ago #1 by laurelle
Hi,

It would just be a matter of fixing the css so the text is positioned where you want it, with Cufon enabled. Your menu module is using absolute and relative positioning which is probably what is throwing the css off when Cufon is enabled.

Good luck.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #2 by legris
Ok.
I disabled the cufon plugin and the text is where it should be. (you can look now, I've disabled)
I guess I'm one of the unlucky few that it will not work for.
Thanks anyway.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #3 by laurelle
Hi,

I don't think that is what is causing the text to be at the top of the tab. You need to add some padding to the text, so it is center in the tab. Try adding some padding-top to:
ul.bows-hmenu a
or it could be the line-height that is causing the issue.

This isn't a cufon plugin problem, but a CSS problem which is outside of the scope of the support.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #4 by legris
Thanks for the quick response.
I assumed I should add that to the template.css file, which I did, but it didn't change anything.
Firebug now has the "top: 1px;" crossed out in the element.style, but the actual position of the text in those areas is still located at the top of the tab.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #5 by laurelle
Hi,

Did you try adding:
cufon canvas {top:0!important;}

You need the !important to override the inline styling.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #6 by legris
Using Joomla 1.7.3
Cufon ver 2.2.0 Beta

Link: Link to view problem site

I have tried unsucessfully for several hours to find and fix the css to not have the top -1px to the top menu and to the module block header.
I have tried adding "padding-top: 10px;" to so many css items, and none of them change what is supposed to be changed.
I have tried using firebug to isolate, but still not working properly.
I'm about to give up.
Thanks in advance.

LeGris
Last edit: 7 years 3 months ago by legris.

Please Log in or Create an account to join the conversation.

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Hosts

Managed Web Hosting by Liquid Web

This is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top