Font size override not working

More
7 years 7 months ago #1 by laurelle
Hi,

Try adding !important to the end of the css rule that changes the font-size. For example:
.cufon-active h2.art-postheader { font-size: 36px!important; }

I will add this to the next version or you can edit the following file:
/plugins/system/kc_cufon/kc_cufon.php
around line 81 you will find this line:
$css .= '.cufon-active '.$sel.' { font-size: '.$fontsize[$i].'; } ';
change it to:
$css .= '.cufon-active '.$sel.' { font-size: '.$fontsize[$i].'!important; } ';
If you make this change then you wouldn't need to use the .cufon-active rule above.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago #2 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
Awesome! There is a Great review and a donation coming your way when this gets resolved.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #3 by laurelle
Hi,

I have done some testing using the default Joomla templates and am having the same issue as you are. I have put in a post in the Cufon group to see if they have any idea what could be causing this issue. The strange thing is that the code is the same for the font size as the Joomla 1.5 plugin, which works.

I will let you know when I find anything out.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago - 7 years 7 months ago #4 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
Unfortunately, It spaced out the paragraphs below the Who we are article. Still did not affect the visible font size.

After adjusting the text size and turning off the plugin it is apparent that the original text IS being affected and as a result adjusting the buffering but the Cufon text is not changing.
Last edit: 7 years 7 months ago by .

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #5 by laurelle
Hi,

There isn't an h1 on the home page. Please try this:
.cufon-active h2.art-postheader { font-size: 36px; }
and see if your font size changes on the "Who we are" header.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago #6 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
Good sir, that had the same effect as using the font size option in the plugin. It pushed the sheet down from the menu as if making room for the larger text however the text stays the same. I figured it may be the menu mod however it doesn't change the h1 headers either.
Thank you for your time.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #7 by laurelle
Hi,

There looks like there might be a bug in the plugin. I will need to do some testing.

In the meantime try adding the followng to your css file:
.cufon-active li { font-size: 36px; }
change the font size to whatever size you want. You can add the same thing for the other selectors and set the font size for them as well.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago #8 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
The tuschha is using Joomla! 1.6.3 Stable at the moment.

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago #9 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
Sure,
I have this on 2 sites and I notice when the font size value is changed it increases the margin between the top menu and the main sheet, this is telling me it is increasing the size but not on the visible Cufon'd font.
tuschha.org
tuschs.org

You will notice the menu text on both are small and need to be re-sized (li being used along side of h1 & h2), however no amount of script changes seem to work.
Thanks for the quick response BTW.

Please Log in or Create an account to join the conversation.

More
7 years 7 months ago #10 by laurelle
Hi,

Can you send a link to your site please.

I don't remember what was the issue with the previous posters site.

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

  • Uhlbelk
7 years 7 months ago #11 by Uhlbelk
Replied by Uhlbelk on topic Font size override not working
I currently have this issue with a Joomla! 1.7.0 Stable [Ember] install.
I am using Cufón System Plugin for Joomla 1.6.x - Version 2.1.0 Beta Which is otherwise a brilliant script.

I understand that it's beta but perhaps the solution you gave to the original poster could be relevant in this case.

Please Log in or Create an account to join the conversation.

More
8 years 2 weeks ago #12 by buddyq
I did send you an email.

Please Log in or Create an account to join the conversation.

More
8 years 2 weeks ago #13 by laurelle
Hi,

Please use the Contact Us form to send me the info so I can view the site.

Did you try different browsers?
Have you used a Strict doctype?

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
8 years 2 weeks ago #14 by buddyq
Plugin version 1.4.0
Joomla 1.5.22

I did try other sizes.

I can PM or email you a login to the page so you can get it. It is for the title on the site...

www.311addieroy.com

This site is OFFLINE but you can see it if you login. I need to send you a login. I can give you a login.

Please Log in or Create an account to join the conversation.

More
8 years 2 weeks ago #15 by laurelle
Hi Buddy,

What version of the plugin are you using? What version of Joomla? What browser are you testing this in?

Can you pass me a link to your site, so I can look at the code?

Did you try using different values and see if the size changed?

Laurelle
Developer
Keashly.ca Consulting

Please Log in or Create an account to join the conversation.

More
8 years 2 weeks ago #16 by buddyq
Putting in font-size in the plugin settings does not override the settings from my css. My css does not use !important either, just fyi in case you are going to ask. So it seems like that part of the plugin is not working. Is there anything i might be missing to do on my end? I'm just reading the instructions and have '44px' in the box for the font-size. Everything else is working very nicely and I love the plugin.

Buddy

Please Log in or Create an account to join the conversation.

Support Development

Please consider a small donation to support development of the extensions on this site.



Joomla! Login

This is the normal Joomla! login module not the VirtueMart login module. Click the 'Create an account' button to see how you are redirected to the VirtueMart registration form when the KC VM Registration Redirect plugin is enabled.

Joomla! & WordPress Hosts

Managed Web Hosting by Liquid Web

This is our recommended web hosting provider for Joomla! & WordPress websites. This is the host that we use for websites that we build. Liquid Web has an excellent reputation, fast servers and most importantly awesome service! They have technicians that are familiar with Joomla! & WordPress.

Joomla! & WordPress Web Design and Development

If you are interested in having a website designed or redesign or need custom Joomla! or WordPress development, please visit Keashly.ca Consulting to view our Portfolio of Joomla! & WordPress website work.

Trademarks and logos remain the property of their respective organizations.
The Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
Keashly.ca Consulting is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.

Site Map Back to Top